Find Answers

Canvas/RamCT Blackboard

CSU is currently upgrading its Learning Management System (LMS) from RamCT Blackboard to Canvas. During this time, courses may be available in either RamCT or Canvas depending upon the LMS choice of your instructor.

Canvas Mobile

Canvas is built on open web standards and uses minimal instances of Flash, so most features are supported on mobile devices. With the growing use of mobile devices, instructors should build their courses with best practices for mobile in mind. Click here for more specific information regarding Canvas Mobile.

Blackboard Mobile

Blackboard Mobile LearnThe Blackboard Mobile Learn App allows you to browse your courses, participate in discussions, check grades, and view class recordings for some courses.

To use the app:

  • Download the free Blackboard Mobile Learn app from your mobile device's app store.
  • Start the app and search for Colorado State University.
  • Log in with your eID (credit students) or noncredit login ID (noncredit students).
  • Go to Courses and select a class.

Canvas Supported Browsers

Access to Canvas requires a personal computer with the following capabilities:

Supported Browsers

Because it's built using web standards, Canvas runs on Windows, Mac, Linux, iOS, Android, or any other device with a modern web browser.

Canvas supports the last two versions of every browser release. We highly recommend updating to the newest version of whatever browser you are using, as well as the most up-to-date Flash plug-in.

As of October 24, 2014, we support the following desktop browsers and Flash versions:

  • Internet Explorer 10 and 11
  • Chrome 37 and 38
  • Safari 6 and 7
  • Firefox 32 and 33 (Extended Releases are not supported)
  • Flash 14 and 15 (for recording or viewing audio/video and uploading files)
  • Respondus Lockdown Browser (supporting the latest system requirements)

Some supported browsers may still produce a banner stating: Your browser does not meet the minimum requirements for Canvas. If you have upgraded your browser but you are still seeing the warning banner, try logging out of Canvas and deleting your browser cookies. Click here for help with clearing your cache.

If you are using an unsupported browser, you can update your browser, or you can dismiss the warning banner during the duration of your browser session. For instance, testing centers can dismiss the banner and it won't appear until the next browser session.

Required Components

Flash is required in a few places in Canvas, including media recording/streaming and viewing, as well as uploading files to a course or an assignment. Other than these features, Flash is not required to use most areas of Canvas.

The Java plug-in is required for screen sharing in conferences. Please note that some browsers do not support Java. There are no other browser plug-ins used by Canvas.

Minimum Computer Requirements for RamCT

Access to RamCT/RamCT Blackboard requires a personal computer with the following software/capabilities:

  • Operating system - Windows 7, Vista, or XP; or MacOSX 10.5 or higher (Leopard or Snow Leopard)
  • High-speed internet connection - cable, DSL, or wireless
  • Compatible web browser
    • Internet Explorer 8.0 or higher
    • Firefox 3.6 or higher
    • Safari 3.2 or higher
    • Google Chrome
  • Java 6

Canvas Orientation

New to Canvas? To learn more about assignments, assessments, messaging, collaboration, and more within Canvas, check out the Canvas Quickstart Guide.

RamCT Blackboard Orientation

New to RamCT Blackboard? To learn more about assignments, assessments, messaging, collaboration, and more within RamCT Blackboard, check out the RamCT Blackboard Orientation Course.

Loading...